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Introduction 
Adobe Flash CS4 is the industry standard software for creating rich, interactive content ranging 
from simple animations to full-featured web applications. Flash includes many features that 
make it powerful but easy to use. In addition, Flash includes a scripting language that can be 
used to add interactivity and complex functionality to Flash projects. This handout covers the 
basics of Flash CS4, including getting familiar with the user interface, working with layers, and 
creating vector graphics using different drawing tools. 

Downloading the Data Files 
This handout includes sample data files that can be used for hands-on practice. The data files are 
stored in a self-extracting archive. The archive must be downloaded and executed in order to 
extract the data files. 

 The data files used with this handout are available for download at 
http://www.calstatela.edu/its/training/datafiles/flashcs4p1.exe. 

 Instructions on how to download and extract the data files are available at 
http://www.calstatela.edu/its/docs/download.php. 

Launching the Program 
When Flash CS4 is launched, the Welcome Screen displays. This screen provides quick access to 
the most recently opened files and shortcuts for creating new documents. In addition, this screen 
can be used to access useful support documentation and video tutorials. 
 
To launch Flash CS4: 

1. Click the Start button, point to All Programs, point to Adobe Design Premium CS4, 
and select Adobe Flash CS4 Professional. The program opens and the Welcome Screen 
displays (see Figure 1). 

 
Figure 1 – Flash CS4 Welcome Screen 

http://www.calstatela.edu/its/training/datafiles/flashcs4p1.exe�
http://www.calstatela.edu/its/docs/download.php�
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Creating a New Document 
In Flash CS4, a new document can be created from the Welcome Screen or from the File menu. 
Use one of the methods below to create a new document. 
 
To create a new document from the Welcome Screen: 

1. Click Flash File (ActionScript 3.0) in the Create New section of the Welcome Screen 
(see Figure 1). A new blank document labeled Untitled-1 opens. 
NOTE

 
: Adobe Flash Player 9 or later is required in order to open an ActionScript 3.0 Flash file. 

To create a new document from the File menu: 
1. Click the File menu and select New. The New Document dialog box opens (see Figure 

2). 
2. On the General tab, select Flash File (ActionScript 3.0) from the Type list. 
3. Click the OK button. A new blank document labeled Untitled-1 opens. 

 
Figure 2 – New Document Dialog Box 

Exploring the Interface 
The Flash CS4 interface includes various elements such as tools and panels that help users create 
and manipulate Flash documents. Any arrangement of these elements is called a workspace. 
Users can adapt the program to the way they work by selecting from several preset workspaces 
or by creating their own workspace. The main elements of the Flash CS4 default workspace are 
the Stage, the Timeline, the Application bar, the Property inspector, the Library panel, and the 
Tools panel (see Figure 3). 
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Figure 3 – Flash CS4 Interface 

Panels 
Panels help users streamline their workflow by giving them easy access to many of the most 
commonly used features in Flash. Many panels include a menu with additional options that can 
be accessed by clicking the menu icon  in the upper-right corner of the panel. 

Library Panel 
The Library panel is used to store and organize symbols created in Flash as well as imported 
files, including bitmap graphics, sound files, and video clips. 
 
To display the Library panel: 

1. Click the Window menu and select Library. Or, press Ctrl+L (see Figure 4). 

 
Figure 4 – Library Panel 
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Property Inspector 
The Property inspector provides quick and easy access to the most commonly used attributes of 
the currently selected element or tool. The options available in the Property inspector depend on 
the current selection. 
 
To display the Property inspector: 

1. Click the Window menu and select Properties (see Figure 5). 

 
Figure 5 – Property Inspector 

The Timeline 
The Timeline is used to organize and control a document’s content (see Figure 6). The major 
components of the Timeline are layers, frames, and the playhead. Layers are listed in a column 
on the left side of the Timeline. Controls in the layers section let users hide, show, lock, or 
unlock layers. Frames contained in each layer appear in a row to the right of the layer name. The 
Timeline header at the top of the Timeline indicates frame numbers. The playhead indicates the 
current frame displayed on the Stage. The Timeline status bar displayed at the bottom of the 
Timeline indicates the selected frame number, the current frame rate, and the elapsed time to the 
current frame. A document’s content can be separated into multiple scenes. Each scene has its 
own Timeline. 

 
Figure 6 – The Timeline 
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Tools Panel 
The Tools panel contains a group of selection tools, drawing and type tools, painting and editing 
tools, navigation tools, and tool options that are used to create and modify graphic objects (see 
Figure 7). 

 
Figure 7 – Tools Panel 

The Stage 
The Stage is the rectangular area where users place graphic content when creating Flash 
documents. What displays on the Stage depends on the layer and frame that is selected in the 
Timeline. 

Changing Document Properties 
Users can change the properties of new or existing documents. 
 
To change the document properties: 

1. In the Property inspector, under Properties, click the Edit button next to Size. The 
Document Properties dialog box opens (see Figure 8). 

2. Next to Dimensions, type 550 px in the width box and 400 px in the height box. 
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Figure 8 – Document Properties Dialog Box 

3. Click the Background color control , and then select a color swatch from the palette 
or enter a color’s hexadecimal value in the box (see Figure 9). 

 
Figure 9 – Background Color Palette 

4. Click the OK button to apply the changes. 

Working with Layers 
Layers help users organize the artwork, animation, and other elements in a Flash document. 
When a document has multiple layers, users can draw and edit objects on one layer without 
affecting objects on another layer. To work with a layer, it must first be selected in the Timeline 
to make it active. A pencil icon next to a layer in the Timeline indicates that the layer is active. 
When a new Flash document is created, it contains only one layer. Users can easily add, delete, 
rename, hide, lock, or rearrange layers. 
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Adding and Deleting Layers 
When a new layer is created, it appears above the selected layer. The newly added layer becomes 
the active layer. 
 
To add a layer: 

1. Click the File menu and select Open. The Open dialog box opens. 
2. Navigate to the data files folder, select the Part1.fla file, and then click the Open button. 
3. In the Timeline, click one of the existing layers to select it. 
4. Click the New Layer button  at the bottom of the Timeline (see Figure 10). A new 

layer is created above the selected layer and is given a default name. 
NOTE

 

: Flash displays layers from the bottom up. It displays the contents of the bottom layer first; 
then, on top of that layer, it displays the contents of the next layer up; and so on. To change the 
order of layers, drag the layer name in the Timeline to a new position. 

To delete a layer: 
1. In the Timeline, click one of the existing layers to select it. 
2. Click the Delete button  at the bottom of the Timeline (see Figure 10). 

 
Figure 10 – Layers Section of the Timeline 

Renaming Layers 
By default, new layers are named by the order in which they are created: Layer 1, Layer 2, Layer 
3, and so on. Layers should be renamed to better reflect their contents. 
 
To rename a layer: 

1. In the Timeline, double-click the layer name, type the new name, and press the Enter 
key (see Figure 10). 

Locking and Unlocking Layers 
Locking a layer prevents its contents from being selected and accidentally changed. 
 
To lock or unlock a layer: 

1. In the Timeline, click in the Lock column to the right of the layer name (see Figure 10). 
A padlock icon  appears next to the layer name to indicate that it is locked. 

2. To unlock the layer, click in the Lock column again. The padlock icon  disappears to 
indicate that the layer is unlocked. 
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NOTE: To lock all layers, click the padlock icon  at the top of the Lock column. To unlock all 
layers, click the padlock icon  again. 

Showing and Hiding Layers 
Users can choose to have all layers visible or show only the one they are working on. 
 
To show or hide a layer: 

1. In the Timeline, click in the Eye column to the right of the layer name (see Figure 10). A 
red x icon  appears next to the layer name to indicate that it is hidden. 

2. To show the layer, click in the Eye column again. The red x icon  disappears to 
indicate that the layer is visible. 
NOTE: To hide all layers, click the eye icon  at the top of the Eye column. To show all layers, 
click the eye icon  again. 

Working with Graphics 
The drawing tools in Flash can be used to create and modify lines and shapes which are vector 
based. Vector graphics can be scaled to any size without losing quality because the points, 
curves, and lines that create vectors are resolution-independent. Using vector graphics in a file 
can help keep the file size small. 

Creating Rectangles 
The Rectangle tool can be used to create basic geometric shapes and apply strokes and fills. 
 
To create a rectangle: 

1. Create a new Flash document. 
2. In the Timeline, rename Layer 1 to Boat. 
3. Select the Rectangle tool  in the Tools panel. 
4. Click the Stroke Color and Fill Color controls in the Tools panel and select a color 

swatch from each palette. 
5. On the Stage, drag the mouse pointer to draw a rectangle. 

 
To modify the rectangle: 

1. Select the Selection tool  in the Tools panel. 
2. Drag the mouse pointer around the entire rectangle to select the stroke and the fill (see 

Figure 11). 

 
Figure 11 – Selected Rectangle 

3. In the Property inspector, under Position and Size, change the W (width) value to 168 
and the H (height) value to 35 by dragging the hot text or by clicking the hot text and 
entering the new value (see Figure 12). 

4. Under Fill and Stroke, click the Stroke Color control and select the desired color from 
the palette. 

5. Type 2 in the Stroke Height box and press the Enter key (see Figure 12). The rectangle 
now has a thick, colored stroke. 
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Figure 12 – Property Inspector Displaying the Rectangle Properties 

Applying a Bitmap Fill 
Users can apply a solid color, gradient, or bitmap (such as a TIFF, JPEG, or GIF file) to a 
shape’s fill. Shapes can also have no fill. To apply a bitmap fill to a shape, the bitmap must be 
imported into the current file. 
 
To apply a bitmap fill: 

1. Make sure the entire rectangle is selected. 
2. Click the Window menu and select Color. The Color panel displays (see Figure 13). 
3. In the Color panel, click the Fill icon  to display the Fill Color attributes. 

 
Figure 13 – Color Panel 

4. Click the Type arrow and select Bitmap from the list (see Figure 13). The Import to 
Library dialog box opens. 

5. Locate and select the Wood.jpg file, and then click the Open button. The rectangle fills 
with the wood image (see Figure 14). 
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Figure 14 – Rectangle Filled with Wood Image 

Modifying Objects 
To adjust the shape of the rectangle: 

1. Make sure the entire rectangle is selected. 
2. Select the Free Transform tool  in the Tools panel. Transformation handles appear 

around the rectangle (see Figure 15). 

 
Figure 15 – Modifying a Rectangle Using Transformation Handles 

3. Press and hold Ctrl+Shift as you drag one of the bottom corner handles inward. This 
simultaneously moves the selected corner and the adjoining corner equal distances from 
their original location. 

4. Click outside the shape to deselect it. It now looks more like a boat. 

Drawing with the PolyStar Tool 
To create a triangle using the PolyStar tool: 

1. Select the PolyStar tool  in the Tools panel. 
: If the PolyStar tool is not displayed, click and hold the mouse button on the Rectangle 

tool , and then select the PolyStar tool from the pop-up menu. 

Figure 16). 

NOTE

2. In the Property inspector, under Tool Settings, click the Options button. The Tool 
Settings dialog box opens (see 

 
Figure 16 – Tool Settings Dialog Box 

3. Type 3 in the Number of Sides box, and then click the OK button. 
4. In the Property inspector, under Fill and Stroke, click the Fill Color control and select 

the desired color from the palette. 
5. On the Stage, drag the mouse pointer to draw a triangle. 
6. Select the Free Transform tool  in the Tools panel. 
7. On the Stage, drag the mouse pointer around the triangle to select it. Transformation 

handles appear around the triangle (see Figure 17). 
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8. Modify the triangle as necessary to transform it into a sail and move it above the boat. 
 To rotate the triangle, position the mouse pointer just outside a corner handle and 

drag. 
 To resize the triangle, drag a corner handle diagonally to scale in two dimensions, or 

drag a side handle horizontally or vertically to scale in the respective direction only. 
 To skew the triangle, position the mouse pointer on the outline between the 

transformation handles and drag. 
 To move the triangle, position the mouse pointer over the triangle (within the 

bounding box) and drag. Do not drag the transformation handles. 
9. Click outside the shape to deselect it. It now looks more like a sail (see Figure 17). 

 
Figure 17 – A Triangle Transformed into a Sail 

Drawing with the Line Tool 
The Line tool is used to draw straight lines in any direction. 
 
To create a pole using the Line tool: 

1. Select the Line tool  in the Tools panel.  
2. In the Property inspector, under Fill and Stroke, click the Stroke Color control and 

select the desired color from the palette (see Figure 18). 
3. Type 5 in the Stroke Height box and press the Enter key.  
4. Click the Cap arrow and select Square from the list. 

 
Figure 18 – Line Tool Property Inspector 

5. Hold down the Shift key and drag the mouse pointer vertically to draw a straight line on 
the Stage. 

6. Move the line to the left of the triangle. 
7. Draw a short horizontal line above the vertical line. The line looks more like a pole now 

(see Figure 19). 
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Figure 19 – Boat 

Applying a Gradient Fill 
A gradient is a multicolor fill in which one color gradually changes into another color. Flash can 
be used to create linear gradients, which change color along a linear path (horizontal or vertical), 
or radial gradients, which change color in an outward direction starting from a central focal 
point. 
 
To apply a gradient fill: 

1. Select the Selection tool  in the Tools panel. 
2. On the Stage, double-click the triangle to select both the stroke and the fill. 
3. In the Color panel, click the Fill icon . 
4. Click the Type arrow and select Radial from the list. 
5. Click on or below the gradient definition bar to add a color pointer  to the gradient. 
6. Drag the new pointer to the middle of the gradient definition bar. 
7. Select the new pointer, and then click in the color space that appears above the gradient 

bar to change the color. 
NOTE  The triangle at the top of a pointer turns black when selected. 

8. Select the far-left and far-right pointers and select the desired colors from the color space. 
The gradient fill consisting of three colors is applied to the sail (see 

:

Figure 20). 

 
Figure 20 – Radial Gradient Selected in the Color Panel 

Using the Gradient Transform Tool 
The Gradient Transform tool can be used to adjust the size, direction, or center of a gradient fill. 
 
To modify the gradient fill in the sail: 

1. Select the Gradient Transform tool  in the Tools panel.  
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: If the Gradient Transform tool is not displayed, click and hold the mouse button on the 

Free Transform tool , and then select the Gradient Transform tool from the pop-up menu. 

NOTE

2. On the Stage, click within the sail. Transformation handles appear around the sail (see 
Figure 21). 

3. Drag the square handle  on the edge of the bounding circle to stretch the gradient fill 
horizontally. 

4. Drag the middle circular handle  on the edge of the bounding circle to stretch the 
overall gradient fill. 

5. Drag the bottom circular handle  on the edge of the bounding circle to rotate the 
gradient fill. 

6. Drag the inverted triangle  in the center of the bounding circle to change the center of 
the gradient. 

7. Drag the circular handle  in the middle of the bounding circle to move the gradient fill 
within the sail. 

 
Figure 21 – Gradient Transformation Handles 

Making Selections 
In Flash, objects can be selected using the Selection tool, Subselection tool, or Lasso tool. The 
Selection tool is used to select an entire object or a section of an object. The Subselection tool is 
used to select a specific anchor point in a vector path. The Lasso tool is used to draw a freeform 
selection. 

Selecting and Grouping Objects 
Groups are collections of graphic objects that are treated as a single unit. Grouping lets users 
move or transform a number of objects without affecting their attributes or relative positions. 
 
To select objects and group them: 

1. Select the Selection tool  in the 
Tools panel. 

2. On the Stage, drag the mouse 
pointer around the boat to select it. 

3. Click the Modify menu and select 
Group (see Figure 22). 

 
Figure 22 – Modify Menu When Selecting Group 
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To edit the newly created group: 
1. Double-click the boat on the Stage. The Edit bar above the Stage now displays Scene 1 

and Group (see Figure 23). 

 
Figure 23 – Edit Bar 

2. Select the pole of the boat using the Selection tool . 
3. Click the Stroke Color control in the Tools panel and select the desired color from the 

palette. 
4. Click Scene 1 on the Edit bar to return to the main scene. 

Using the Lasso Tool 
The Lasso tool lets users select elements that are oddly shaped or too close to other elements to 
allow the use of the selection rectangle. 
 
To create a wave beneath the boat: 

1. Double-click the boat on the Stage. 
2. Select the Lasso tool  in the Tools panel. 
3. On the Stage, drag to draw a wave-like shape beneath the boat, overlap the ends to close 

the selection outline, and then release the mouse button.  
4. Click the Fill Color control in the Tools panel and select blue from the color palette. The 

selected area of the wood bitmap is replaced with a solid blue fill. 
5. Click the Stroke Color control in the Tools panel and click the No Color button  

located in the upper-right corner of the color palette. 
6. Click Scene 1 on the Edit bar to return to the main scene (see Figure 24). 

 
Figure 24 – Boat with Waves 

Using Other Shape Tools 
In addition to creating rectangles and triangles, Flash includes tools that can be used to draw 
circles, ovals, and stars. All these tools can be used to draw a shape as an outline (a stroke) or as 
a solid object (a fill). 
 
To create a moon using the Oval tool: 

1. In the Timeline, create a new layer and rename it to Moon & Stars. 
2. Select the Oval tool  in the Tools panel. 

NOTE: If the Oval tool is not displayed, click and hold the mouse button on the PolyStar tool 
, and then select the Oval tool from the pop-up menu. 
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3. In the Property inspector, under Fill and Stroke, click the Stroke Color control to 
display the color palette, and then click the No Color button . 

4. Click the Fill Color control and select the desired color from the palette. 
5. Hold down the Shift key to constrain the shape and drag the mouse pointer on the Stage 

to draw a circle (see Figure 25). 

 
Figure 25 – Creating a Crescent-shaped Moon 

6. Use the Selection tool  to select the circle, click the Edit menu and select Copy (or, 
press Ctrl+C), and then click the Edit menu and select Paste in Center (or, press 
Ctrl+V). A copy of the circle appears on the Stage. 

7. Select the Free Transform tool , hold down the Shift key to retain the circle’s 
proportions, and drag a corner handle inward to make the second circle smaller. 

8. Use the Fill Color control to select a different color for the second circle. 
9. Move the second circle on top of the first circle to create a crescent-shaped moon. 
10. Click outside the circle to deselect it. 
11. Click the second circle again and press the Delete key to delete it. 
12. Select the newly created moon and move it to the upper-right corner of the Stage. 

 
To create stars using the PolyStar tool: 

1. Select the PolyStar tool  in the Tools panel. 
: If the PolyStar tool is not displayed, click and hold the mouse button on the Oval tool 

, and then select the PolyStar tool from the pop-up menu. 

Figure 16). 

NOTE

2. In the Property inspector, under Tool Settings, click the Options button. The Tool 
Settings dialog box opens (see 

3. Click the Style arrow and select star from the list. 
4. Type 5 in the Number of Sides box, and then click the OK button (see Figure 26). 

 
Figure 26 – Tool Settings Dialog Box 

5. In the Property inspector, under Fill and Stroke, click the Stroke Color control to 
display the color palette, and then click the No Color button . 

6. Click the Fill Color control and select the desired color from the palette. 
7. On the Stage, drag the mouse pointer to draw a few stars (see Figure 27). 
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Figure 27 – Moon and Stars 

Creating Curves 
The Pen tool is used to draw precise paths as straight lines or smooth, flowing curves. 
 
To create a wave-like background graphic using the Pen tool: 

1. In the Timeline, create a new layer and rename it to Wave1. 
2. Drag the Wave1 layer to the bottom of the layer stack (see Figure 28). 
3. Hide the Boat layer. 

 
Figure 28 – Timeline after Rearranging Layers 

4. Select the Pen tool  in the Tools panel.  
5. Click to the left of the Stage to create the first anchor point. 
6. Position the mouse pointer on the Stage to the right of the first anchor point, and then 

drag to establish the second anchor point and to create a smooth curve (see Figure 29).  
NOTE

Figure 29
: The direction lines that appear at an anchor point as you drag can be used to adjust the 

shape of the curve (see ). 

 
Figure 29 – Drawing a Curve Using the Pen Tool 

7. Continue dragging on the Stage to create a series of smooth curves. Make the width of 
the wave wider than the Stage (see Figure 30). 

 
Figure 30 – Smooth Wave Curves 

8. Close the path by clicking on the first anchor point (see Figure 31). 
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Figure 31 – Wave Outline 

9. Select the Paint Bucket tool  in the Tools panel, and then click the Fill Color control 
and select blue from the color palette. 

10. Click anywhere inside the wave outline to fill it with the selected color (see Figure 32). 

 
Figure 32 – Colored Wave 

11. Double-click the wave shape. 
12. In the Property inspector, click the Stroke Color control, and then click the No Color 

button . 

Transparencies 
Transparency is measured as a percentage and is referred to as alpha. An alpha of 100% indicates 
that a color is totally opaque, whereas an alpha of 0% indicates that a color is totally transparent. 
Transparency can be applied to either the stroke or the fill. 

Modifying the Alpha Value of a Fill 
To modify the alpha value of a fill: 

1. Select the wave shape. 
2. Click the Edit menu and select Copy. 
3. Create a new layer and rename it to Wave2. 
4. Click the Edit menu and select Paste in Place. The copy of the wave is placed in the 

same location as the original wave. 
5. Select the Selection tool  and move the copy slightly to the left or to the right of the 

original so the crests of the waves are somewhat offset. 
6. Make sure the copied wave is still selected. 
7. In the Color panel, set the Fill Color to a slightly lighter blue, and then change the 

Alpha value to 50%. The color swatch at the bottom of the Color panel displays a 
preview of the newly selected color (see Figure 33). The Stage now has two waves with 
different color tones (see Figure 34). 
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Figure 33 – Changing the Alpha Value in the Color Panel 

8. Unhide the Boat layer and change the background color to a darker blue (see Figure 34). 

 
Figure 34 – Waves with Different Color Tones  

Text 
In Flash CS4, users can create three types of text fields: static, dynamic, and input. Static text 
fields display text that does not change characters dynamically. Dynamic text fields display 
dynamically updating text. Input text fields allow users to enter text in forms or surveys. 
 
To create static text: 

1. Create a new layer and rename it to Adobe Flash CS4. 
2. Select the Text tool  in the Tools panel. 
3. In the Property inspector, click the Text type arrow and select Static Text from the list 

(see Figure 35). 
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Figure 35 – Selecting Static Text in the Property Inspector 

4. Under Character, click the Family arrow and select a font from the list. 
5. Click the hot text next to Size and enter a new font size. 
6. Click the Color box and select a color swatch from the palette. 
7. Under Paragraph, click the Align center button  to center the text in the text box 

(see Figure 36). 

 
Figure 36 – Paragraph Options in the Property Inspector 

8. Click on the Stage and type Adobe Flash CS4. 
9. Click another part of the Stage to deselect the text box (see Figure 37). 

 
Figure 37 – Stage after Adding Text 

Breaking Apart Text Objects 
The Break Apart command separates each character in the text box into individual static 
characters. It also provides a means to select all of the characters so that a gradient fill can be 
applied to the text object. 
 
To apply a gradient fill to a text object: 

1. Select the Selection tool  in the Tools panel. 
2. Right-click the text on the Stage and select Break Apart (see Figure 38). 
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Figure 38 – Selecting Break Apart from the Shortcut Menu 

3. Right-click the text and select Break Apart one more time. The text is automatically 
selected (see Figure 39). 

 
Figure 39 – The Effect of Break Apart 

4. In the Property inspector, click the Fill Color control and select a gradient fill from the 
palette. 
NOTE: The gradient fill can be modified as desired by following the steps in the Applying a 
Gradient Fill section of this handout. 

Special Effects and Filters 
Filters are special effects that can be applied to text and to certain symbols. 
 
To add a drop shadow to the text: 

1. Create a new layer and rename it to ITS Training. 
2. Select the Text tool , click on the Stage, and type ITS Training. 
3. Select the Selection tool  and click the text on the Stage. 
4. In the Property inspector, expand the Filters section. 
5. In the Filters section, click the Add filter button  and select Drop Shadow from the 

menu (see Figure 40). The Drop Shadow filter appears in the Filters section, and a drop 
shadow is applied to the selected text (see Figure 41).  
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Figure 40 – Selecting Drop Shadow from the Add Filter Menu 

 
Figure 41 – Text with Drop Shadow 

Other Drawing Tools 
Flash includes other useful drawing tools such as the Deco tool, the Brush tool, and the Pencil 
tool. 

Using the Deco Tool 
The Deco tool, which is a new feature in Flash CS4, can be used to create difficult patterns. The 
Deco tool options can help users easily create symmetrical designs, grids, and branching-type 
flourishes.  
 
To draw vines: 

1. Create a new layer and rename it to 
Vines. 

2. Select the Deco tool  in the Tools 
panel. 

3. In the Property inspector, under 
Drawing Effect, click the down arrow 
and select Vine Fill from the list. 

4. Click the color box next to Leaf and 
select a color for the leaf shapes. 

5. Click the color box next to Flower and 
select a color for the flower shapes. 

6. Under Advanced Options, click the 
color box next to Branch angle and 
select a color for the branches. 

7. Click the hot text next to Branch angle 
and enter 0. 

8. Click the hot text next to Pattern scale 
and enter 50 (see Figure 42). 

 
Figure 42 – Deco Tool Property Inspector 
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9. Click once on the Stage to create the fill pattern. Click again to stop the formation. The 
vines appear on the Stage (see Figure 43). 

 
Figure 43 – Text with Vines 

NOTE: The fill pattern cannot be changed after the Vine Fill effect is applied. 

Using the Brush Tool 
The Brush tool draws brush-like strokes and creates special effects, including calligraphic 
effects. The Brush tool modifiers can be used to select a brush size and shape.  
 
To draw a fish: 

1. Create a new layer and rename it to Fish. 
2. Select the Brush tool  in the Tools panel. 
3. In the Property inspector, click the Fill Color control and select the desired color from 

the palette. 
4. Click the hot text next to Smoothing and enter 100. 
5. In the Tools panel, click the Brush Size modifier  and select the desired brush size. 
6. In the Tools panel, click the Brush Shape modifier  and select the desired brush 

shape. 
7. Draw a fish on the Stage (see Figure 44). 

 
Figure 44 – Fish 

Using the Pencil Tool 
The Pencil tool is used to draw lines and shapes in much the same way as a real pencil.  
Users can apply smoothing or straightening to the lines and shapes as they draw by selecting a 
drawing mode for the Pencil tool. 
 
To draw the details of the fish: 

1. Select the Pencil tool  in the Tools panel. 
2. In the Property inspector, click the Stroke Color control and select the desired color. 
3. Type 1 in the Stroke Height box and press the Enter key. 
4. Click the hot text next to Smoothing and enter 100. 
5. In the Tools panel, click the Straighten pencil mode  and select Smooth . 
6. On the Stage, draw details on the fish (see Figure 45). 
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Figure 45 – Fish with Details 

Importing/Exporting Images and Graphics 
A key advantage of Flash CS4 is that users can import images created in other applications and 
use those assets in their Flash documents. In addition, images created in Flash CS4 can be 
exported and used in other applications. 

Importing Images into Flash 
Flash lets users import vector graphics and bitmaps in various file formats (e.g., .ai, .psd, .bmp, 
.gif, .jpg, .png) either directly to the Stage or to the Library. 
 
To import images to the Library: 

1. Click the File menu, point to Import, and select Import to Library. The Import to 
Library dialog box opens (see Figure 46). 

 
Figure 46 – Import to Library Dialog Box 

2. While holding down the Shift key, select the seashell1.png, seashell2.png, and 
seashell3.png files. 

3. Click the Open button. The images are added to the Library panel. 
4. Create a new layer and rename it to Seashells. 
5. Drag the seashell1.png, seashell2.png, and seashell3.png files from the Library panel 

to the Stage (see Figure 47). 
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Figure 47 – Imported Seashells 

Exporting as a Bitmap Image 
Users can create bitmap images from Flash content and use them in other applications. 
 
To export the Flash file as a bitmap image: 

1. Click the File menu, point to Export, and select Export Image. The Export Image 
dialog box opens. 

2. Click the Save in arrow and select a location to save the file. 
3. Click the Save as type arrow and select Bitmap (*.bmp) from the list (see Figure 48). 

 
Figure 48 – Export Image Dialog Box 

4. Type a name for the file in the File name box. 
5. Click the Save button. The Export Bitmap dialog box opens (see Figure 49). 

 
Figure 49 – Export Bitmap Dialog Box 

6. Click the Include arrow and select Full Document Size from the list. 
7. Click the Color depth arrow and select 32 bit color w/ alpha from the list. 
8. Click the OK button. 
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Saving Flash Documents 
When a file is saved in Flash, the default format is FLA. FLA files have the .fla file extension 
and can only be edited using Flash. When an FLA file is published, Flash creates a SWF file 
which has the .swf file extension. Users can then use Adobe Flash Player to play the SWF file in 
a web browser or as a stand-alone application. The SWF format is well suited for delivery over 
the Internet because its files are very small. 
 
NOTE

 

: When a Flash document contains unsaved changes, an asterisk (*) appears after the document 
name on the document tab. When the document is saved, the asterisk is removed. 

To save a Flash document in the FLA format: 
1. Click the File menu and select Save. The Save As dialog box opens. 
2. Click the Save in arrow and select a location to save the file. 
3. Type a name for the file in the File name box. 
4. Click the OK button. 

Getting Help 
The Adobe website provides a comprehensive user guide on Flash CS4 that users can search and 
browse. In addition, Community Help gives users access to community-generated content which 
includes the most useful, relevant, and up-to-date information about Adobe products. 
 
To access Flash Help: 

1. Type a search term in the search box on the Application bar, and then press the Enter 
key (see Figure 50). A web browser opens and displays the Flash Help website with a list 
of search results. 

 
Figure 50 – Adobe Flash CS4 Search Box 

NOTE: The search results are sorted according to their relevance. 

2. Click on a topic to view the full details. 
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