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Introduction 
Adobe Flash CS4 is the industry standard software for creating rich, interactive content ranging 
from simple animations to full-featured web applications. Flash includes many features that 
make it powerful but easy to use. In addition, Flash includes a scripting language that can be 
used to add interactivity and complex functionality to Flash projects. This handout covers 
creating and manipulating different types of symbols as well as adding sound and video files into 
a Flash document. 

Downloading the Data Files 
This handout includes sample data files that can be used for hands-on practice. The data files are 
stored in a self-extracting archive. The archive must be downloaded and executed in order to 
extract the data files. 

 The data files used with this handout are available for download at 
http://www.calstatela.edu/its/training/datafiles/flashcs4p2.exe. 

 Instructions on how to download and extract the data files are available at 
http://www.calstatela.edu/its/docs/download.php. 

About Symbols 
Symbols are reusable objects that can be used for special effects, animation, and interactivity. 
There are three types of symbols: graphic, button, and movie clip. An instance is a copy of a 
symbol located on the Stage or nested inside another symbol. An instance can differ from the 
original symbol in color, size, and function. Editing the symbol updates all of its instances, but 
applying effects to an instance of a symbol updates only that instance. Using symbols in Flash 
documents greatly reduces file size and download time. 

Creating Symbols 
When a symbol is created, it is stored in the Library along with the original file. Users can create 
a symbol from selected objects on the Stage, or they can create an empty symbol and make or 
import the content in symbol-editing mode. Users can also duplicate an existing symbol and use 
it as a starting point for creating a new symbol. 

Creating Graphic Symbols 
Graphic symbols are used for static images and to create reusable pieces of animation that are 
tied to the main Timeline. Graphic symbols add less to the FLA file size than buttons or movie 
clips because they have no Timeline. 
 
To create a graphic symbol: 

1. Click the Start button, point to All Programs, point to Adobe Design Premium CS4, 
and select Adobe Flash CS4 Professional. The program opens and the Welcome Screen 
displays. 

2. Click Open in the Open a Recent Item section of the Welcome Screen. The Open 
dialog box opens. 

3. Navigate to the data files folder, select the rocket.fla file, and then click the Open 
button. 

http://www.calstatela.edu/its/training/datafiles/flashcs4p2.exe�
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4. Click the Insert menu and select New Symbol. The Create New Symbol dialog box 
opens (see Figure 1). 

5. Type stars in the Name box. 
6. Click the Type arrow and select Graphic from the list. 
7. Click the OK button. 

 
Figure 1 – Create New Symbol Dialog Box (stars) 

 
To create a star-filled background: 

1. In the Tools panel, click and hold the mouse button on the Rectangle tool , and then 
select the PolyStar tool  from the pop-up menu. 

2. In the Property inspector, click the Options button under Tool Settings. The Tool 
Settings dialog box opens (see Figure 2).  

3. Click the Style arrow and select star from the list. 
4. Click the OK button. 

 
Figure 2 – Tool Settings Dialog Box 

5. In the Property inspector, under Fill and Stroke, click the Fill Color control and select 
the color white (#FFFFFF) from the palette. 

6. Drag the mouse pointer on the Stage to create a star. 
7. Repeat step 6 until there are a dozen stars on the Stage (see Figure 3). 
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Figure 3 – Background with Stars 

To create an instance of the symbol on the Stage: 
1. Click Scene 1 on the Edit bar to return to the main scene. 
2. Select the Selection tool  in the Tools panel. 
3. Select the background layer in the Timeline. 
4. Click the Library tab to display the Library panel. 
5. Drag the stars graphic symbol from the Library panel to the Stage. 

: To move the stars graphic symbol, position the mouse pointer over one of the stars on the 
Stage and drag. To edit the stars graphic symbol, double-click one of the stars on the Stage to 
return to edit mode. 

NOTE

Preparing Graphics for a Movie Clip 
To create a graphic symbol for a movie clip: 

1. Click the Insert menu and select New Symbol. The Create New Symbol dialog box 
opens (see Figure 4). 

2. Type red_flame in the Name box. 
3. Click the Type arrow and select Graphic from the list. 
4. Click the OK button. 

 
Figure 4 – Create New Symbol Dialog Box (red_flame) 
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5. Select the Pen tool  in the Tools panel.  
6. In the Property inspector, under Fill and Stroke, click the Stroke Color control and 

select the color red (#FF0000) from the palette. 
7. Click on the Stage to establish the first anchor point. 
8. Continue clicking on the Stage to create a flame shape similar to Figure 5. 
9. Close the path by clicking on the first anchor point. 
10. Select the Paint Bucket tool  in the Tools panel. 
11. In the Property inspector, under Fill and Stroke, click the Fill Color control and select 

the color red (#FF0000) from the palette. 
12. Click anywhere inside the flame shape outline to fill it with the color red (see Figure 5). 

 
Figure 5 – Creating a Red Flame 

 
To duplicate the symbol: 

1. Select the Selection tool  in the Tools panel. 
2. In the Library panel, right-click the red_flame graphic symbol and select Duplicate. 

The Duplicate Symbol dialog box opens (see Figure 6). 
3. Type orange_flame in the Name box. 
4. Click the OK button. 

 
Figure 6 – Duplicate Symbol Dialog Box (orange_flame) 

To change the fill color of the duplicated symbol: 
1. In the Library panel, double-click the icon  next to the orange_flame graphic symbol. 
2. On the Stage, double-click the graphic to select both the stroke and the fill. 
3. In the Property inspector, under Fill and Stroke, click the Stroke Color control and 

select No Color . 
4. Click the Fill Color control and select the color orange (#FF9900) from the palette. The 

red fill is replaced with the orange fill (see Figure 7). 
5. Click Scene 1 on the Edit bar to return to the main scene. 
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Figure 7 – Orange Flame 

Creating a Movie Clip 
Movie clip symbols are used to create reusable pieces of animation. Movie clips have their own 
multiframe Timeline that is independent from the main Timeline. They can contain interactive 
controls, sounds, and even other movie clip instances. 
 
To create a movie clip: 

1. Click the Insert menu and select New Symbol. The Create New Symbol dialog box 
opens (see Figure 8). 

2. Type flame in the Name box. 
3. Click the Type arrow and select Movie Clip from the list. 
4. Click the OK button. 

 
Figure 8 – Create New Symbol Dialog Box (flame) 

To insert graphics into the movie clip: 
1. Drag the red_flame graphic symbol from the Library panel to the Stage. 
2. Drag the orange_flame graphic symbol from the Library panel to the Stage. Place the 

orange_flame graphic over the red_flame graphic to overlap the two symbols (see 
Figure 9). 

 
Figure 9 – Flame Symbol 
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To resize the graphic symbol: 
1. Click the orange_flame graphic symbol on the Stage to select it. 
2. Select the Free Transform tool  in the Tools panel. Transformation handles appear 

around the graphic. 
3. Drag one of the corner handles inward to decrease the size of the orange_flame graphic 

symbol (see Figure 10). 

 
Figure 10 – Resizing the Flame Symbol 

To animate the flame: 
1. Select the Selection tool  in the Tools panel. 
2. In the Timeline, right-click frame 4 and select Insert Keyframe to insert a new 

keyframe. 
3. Click the Modify menu, point to Transform, and select Flip Vertical. 
4. In the Timeline, right-click frame 6 and select Insert Frame (see Figure 11). 

 
Figure 11 – Inserting a Frame in the Timeline 

To insert the movie clip into the graphic symbol: 
1. In the Library panel, double-click the icon  next to the rocketship graphic symbol. 
2. Drag the flame movie clip from the Library panel to the Stage and place it behind the 

rocketship graphic (see Figure 12). 
3. If necessary, use the Free Transform tool  to resize the flame to fit the rocketship 

graphic. 

 
Figure 12 – Rocketship Graphic 
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To create a motion tween: 
1. Click Scene 1 on the Edit bar to return to the main scene. 
2. Select the flying_ship layer in the Timeline. 
3. Drag the rocketship graphic symbol from the Library panel to the left of the Stage (see 

Figure 13). 

 
Figure 13 – Rocketship Graphic Symbol on the Left Side of the Stage 

4. Right-click the rocketship graphic symbol on the Stage and select Create Motion 
Tween. 

5. Drag the rocketship graphic symbol to the right of the Stage. A motion path appears on 
the Stage (see Figure 14). 

 
Figure 14 – Rocketship Graphic Symbol on the Right Side of the Stage 

6. Press Ctrl+Enter to preview the animation. 
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Editing Symbols 
When users edit a symbol, Flash updates all instances of the symbol throughout the document to 
reflect the edits. The name of the symbol being edited appears in the Edit bar at the top of the 
Stage. A symbol can be edited in context with the other objects on the Stage. When using this 
method, other objects are dimmed to distinguish them from the symbol being edited. A symbol 
can also be edited in a separate window by using symbol-editing mode. 
 
To edit the symbol on the Stage: 

1. Double-click the rocketship graphic symbol on the Stage. 
2. Select the body of the rocketship graphic symbol. 
3. In the Property inspector, under Fill and Stroke, click the Fill Color control and select 

the color turquoise (#00FFFF) from the palette. 
4. Click Scene 1 on the Edit bar to return to the main scene. 

 
To edit the symbol in symbol-editing mode: 

1. In the Library panel, double-click the icon  next to the rocketship graphic symbol. 
2. Select one of the wings of the rocketship graphic symbol. 
3. In the Property inspector, under Fill and Stroke, click the Fill Color control and select 

the color purple (#6600FF) from the palette. 
4. Click Scene 1 on the Edit bar to return to the main scene. 

Adding a Sound 
Adding a sound to an animation is a great way to liven up a Flash movie. Flash accepts many 
different audio formats. Sound files are placed into Flash by importing them into the Library. 
Users can synchronize a sound with the animation by using keyframes. 
 
To import a sound file to the Library: 

1. Select the flyby layer in the Timeline. 
2. Click the File menu, point to Import, and select Import to Library. The Import to 

Library dialog box opens. 
3. Locate and select the spaceflyby.au audio file, and then click the Open button. 
4. Drag the spaceflyby.au audio file from the Library panel to the Stage. Sound waves are 

added to the flyby layer in the Timeline (see Figure 15). 
5. Press Ctrl+Enter to preview the animation. 

 
Figure 15 – Timeline with Sound Waves in the Flyby Layer 

Using the Sounds Library 
Flash CS4 includes a Sounds Library containing many useful sounds that can be used for effects. 
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To import a sound from the Sounds Library: 

1. Click the Windows menu, point to Common Libraries, and select Sounds. The Sounds 
Library panel opens (see Figure 16). 

2. Drag the Science Fiction Sci-Fi Electronic Short Computer Calculation 64.mp3 
sound file from the Sounds Library panel to the Library panel. 

3. Right-click the Sounds Library panel tab and select Close. 

 
Figure 16 – Sounds Library Panel 

4. Select the lasers layer in the Timeline. 
5. Right-click frame 10 of the lasers layer and select Insert Blank Keyframe. 
6. Drag the Science Fiction Sci-Fi Electronic Short Computer Calculation 64.mp3 

sound file from the Library panel to the Stage. Sound waves are added to the lasers 
layer in the Timeline (see Figure 17). 

7. Press Ctrl+Enter to preview the animation. 

 
Figure 17 – Timeline with Sound Waves in the Lasers Layer 

Increasing Interactivity 
Flash CS4 can be used to create rich and interactive content. 
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Creating a Button Symbol 
Button symbols can be used to create interactive buttons that respond to mouse clicks, rollovers, 
or other actions. Button symbols contain a specialized internal Timeline with four frames. The 
first three frames display the button’s three possible states; the fourth frame defines the active 
area of the button (see Table 1). ActionScript is required to control button instances. 
 
Table 1 – Button States 

State Description 
Up How the button looks whenever the mouse pointer is not over it. 
Over How the button looks when the mouse pointer is placed over it. 
Down How the button looks when it is clicked. 
Hit The area that responds to the mouse click. 
 
To create a button symbol: 

1. Click the File menu and select Open. The Open dialog box opens. 
2. Locate and select the site_station.fla file, and then click the Open button. 
3. Click the Insert menu and select New Symbol. The Create New Symbol dialog box 

opens (see Figure 18). 
4. Type explore_button in the Name box. 
5. Click the Type arrow and select Button from the list. 
6. Click the OK button. 

 
Figure 18 – Create New Symbol Dialog Box (explore_button) 

To create a text button: 
1. Select the Text tool  in the Tools panel. 
2. In the Property inspector, under Character, click the Family arrow and select OCR A 

Extended from the list. 
3. Click the hot text next to Size and type 20 in the box. 
4. Click the Color box and select the color black (#000000) from the palette. 
5. Click in the center of the Stage and type Explore. 

 
To align the text on the Stage: 

1. Select the Selection tool  in the Tools panel. 
2. Click the Window menu and select Align. The Align panel opens (see Figure 19). 
3. Drag the Align panel by its title bar and place it above the Property inspector and the 

Library panel. 
4. Click to select the To stage button  in the Align panel. 
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5. Click the Align horizontal center button  and the Align vertical center button  
in the Align panel. 

 
Figure 19 – Align Panel 

NOTE

 

: The Align panel can be used to keep all symbols centered. Symbols that are not centered 
may cause positioning problems in the main Timeline. 

To set the Over state of the button symbol: 
1. In the Timeline, right-click the Over frame and select Insert Keyframe. 
2. Click the Explore text on the Stage. 
3. In the Property inspector, click the Color box and select the color grey (#666666) from 

the palette. 
4. In the Timeline, right-click the Down frame and select Insert Keyframe. 
5. In the Timeline, right-click the Hit frame and select Insert Keyframe (see Figure 20). 

 
Figure 20 – Timeline of a Button Symbol 

To insert the button: 
1. Click Scene 1 on the Edit bar to return to the main scene. 
2. In the Timeline, click to select frame 1 of the explore layer. 
3. Drag the explore_button symbol from the Library panel to the Stage. 
4. Right-click frame 2 of the explore layer and select Insert Frame. 

  
To align all the buttons together: 

1. With the explore layer still selected, hold down the Shift key and click to select the 
about and home layers (see Figure 21). 

2. In the Align panel, click to deselect the To stage button . 
3. Click the Align left edge button  and the Distribute vertical center button . 
4. Press Ctrl+Enter to preview the animation and test the buttons. 
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Figure 21 – Three Button Layers Selected in the Timeline 

To preview the next page: 
1. Click the Control menu and select Step Forward One Frame. 

Using the Buttons Library 
A quick way to add a button to a Flash document is by using one of the predesigned buttons in 
the Buttons Library. 
 
To insert a button from the Buttons Library: 

1. Click the Window menu, point to Common Libraries, and select Buttons. The Buttons 
Library panel opens (see Figure 22). 

2. Click the arrow next to the buttons bar folder to expand it. 
3. Drag the bar grey button symbol from the Buttons Library panel to the Library panel. 
4. Right-click the Buttons Library panel tab and select Close. 

 
Figure 22 – Buttons Library Panel 
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Importing and Embedding a Flash Video File 
To import a video into a Flash document, it must be in either the FLV or F4V format. These 
Flash video formats stream high quality video at a very low file size. Users can embed a small, 
short-duration video file directly into a Flash document and publish it as part of the SWF file. 
 
To import and embed a video: 

1. In the Timeline, click to select frame 1 of the video layer. 
2. Click the File menu, point to Import, and select Import Video. The Import Video 

dialog box opens (see Figure 23). 
3. Click the Browse button. The Open dialog box opens. 
4. Locate and select the mars_video.f4v video file, and then click the Open button. 
5. Click the Next button. 

 
Figure 23 – Selecting a Video File in the Import Video Dialog Box 

6. Click the Skin arrow and select SkinUnderAll.swf from the list (see Figure 24). 
7. Click the Color box and select the color black (#000000) from the palette. 
8. Click the Next button. 
9. Click the Finish button. 

NOTE: The video is imported directly onto the Stage. 
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Figure 24 – Selecting a Video Skin in the Import Video Dialog Box 

To resize the video: 
1. Make sure the mars_video.f4v video is selected on the Stage. 
2. Select the Free Transform tool  in the Tools panel. Transformation handles appear 

around the video. 
3. Drag the handles to resize the video.  
4. Position the video under the Video heading. 

 
To change the Playback settings: 

1. Select the Selection tool  in the Tools panel. 
2. Select the mars_video.f4v video on the Stage. 

3. In the Property inspector, click the Component Inspector panel button . The 
Component Inspector panel opens. 

4. Click the value next to autoPlay, click the down arrow that appears, and select false (see 
Figure 25). 
NOTE: Setting autoPlay to true makes the video play automatically when the site loads. 

5. Right-click the Component Inspector panel tab and select Close. 
6. Press Ctrl+Enter to preview the video in the SWF file. 
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Figure 25 – Component Inspector Panel 

Manipulating Symbols 
Blend effects, masks, and filters can be used to change the appearance of symbols. 

Applying Blend Effects 
Blend effects change the appearance of an image on the Stage by combining it with the color 
content of objects beneath it. Some of the effects include darken, multiply, lighten, and screen. 
 
To insert a symbol: 

1. In the Timeline, click the eye icon  at the top of the Eye column to hide all layers. 
2. Click the red x icon  next to the background layer to show the layer. 
3. Select the background layer in the Timeline. 
4. Drag the galaxy_overlay symbol from the Library panel to the Stage. 

 
To apply a blend effect: 

1. In the Property inspector, click the arrow next to Display to expand the section. 
2. Under Display, click the Blending arrow and select Hard Light from the list (see Figure 

26). 
3. In the Timeline, right-click frame 2 of the background layer and select Insert 

Keyframe. 
4. Double-click the eye icon  at the top of the Eye column to show all layers. 



Adobe Flash CS4, Part 2 17 

 
Figure 26 – Display Section of the Property Inspector 

Masking 
Applying a mask creates a hole through which underlying layers are visible. A mask item can be 
a filled shape, a type object, an instance of a graphic symbol, or a movie clip. 
 
To create a mask: 

1. In the Timeline, click to select frame 2 of the mask layer. 
2. Drag outerspace.jpg from the Library panel to the Stage and place it on top of the 

planet shape (see Figure 27). 
3. In the Timeline panel, right-click the planet layer and select Mask. 
4. Press Ctrl+Enter to preview the SWF file. 

 
Figure 27 – Masking Effect 

Applying Filters 
Filters can be used to add interesting visual effects to text, buttons, and movie clips. Multiple 
filters can be applied to a single object. Flash includes preset filters such as drop shadow, blur, 
glow, and bevel. 
 
To apply a filter: 

1. In the Timeline, click to select frame 1 of the title layer. 
2. Click the International Space Alien Station text on the Stage. 
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3. In the Property inspector, click the arrow next to Filters to expand the section. 
4. In the Filters section, click the Add filter button  and select Drop Shadow. The Drop 

Shadow filter appears in the Filters section (see Figure 28), and a drop shadow is applied 
to the selected text.  

5. Click the hot text next to Blur X and type 6 in the box. 
6. Click the hot text next to Blur Y and type 6 in the box. 
7. Click the hot text next to Strength and type 35 in the box. 
8. Click the hot text next to Distance and type 2 in the box. 
9. In the Timeline, right-click frame 2 of the title layer and select Insert Keyframe. 
10. Press Ctrl+Enter to preview the SWF file. 

 
Figure 28 – Filters Section of the Property Inspector 
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